TYPO3: wt_twitter per TypoScript einbinden

Herrje, ich fange mich versehentlich an zu spezialisieren… bzw. zu langweilen. Es geht mal wieder um die Einbidnung eines Extbase Plugins über TypoScript. Wie schon hier und hier. Dieses Mal am Beispiel wt_twitter. Ich habe selbst nichts dazu gefunden und musste daher ziemlich viel rum probieren. Vielleicht hilft es ja jetzt jemandem weiter. Vielleicht mache aber auch nur ich es mir damit immer wieder so schwer.

Also, ohne große Worte, ein Beispiel-Script zur Einbindung unter Typo3 4.5:

plugin.tx_wttwitter {
  settings.setup {
    mode = showFromSearch
  }
  view {
    templateRootPath = fileadmin/templates/ext/tx_wttwitter/
  }
}
 
 
plugin.tx_wttwitter.widgets {
  listWidget = USER
  listWidget {
    userFunc = tx_extbase_core_bootstrap->run
    pluginName = List
    extensionName = WtTwitter
    controller = Twitter    
    action = list
 
    switchableControllerActions {
        Twitter {
            1 = list
        }
    }
 
    settings =< plugin.tx_wttwitter.settings
    persistence =< plugin.tx_wttwitter.persistence
    view =< plugin.tx_wttwitter.view
  }
}
 
lib.twitter = COA
lib.twitter {
  10 < plugin.tx_wttwitter.widgets.listWidget
}

Nur noch die Konstanten setzen und dann läuft die Sache. Hat sich seit Typo3 4.4 auf jeden Fall noch mal geändert. Wt_Twitter ist auf jeden Fall ein sehr schöne Extension. Alte Typo3-Extensions bringen mich zur Verzweiflung, aber einmal in Extbase und Fluid eingestiegen, kann man sich jetzt endlich auch in fremde Plugins einfinden, ohne dafür Tage zu brauchen. Auch das neue TypoScript cObject FLUIDTEMPLATE macht übrigens richtig Spaß. Auch wenn ich Fluid noch eher suboptimal find… ähm, ja. Ich schweife ab. Das zum Thema „ohne große Worte“.

3 thoughts on “TYPO3: wt_twitter per TypoScript einbinden”

  1. dankeschön :-)

    finds auch immer doof wenn für extensions in der doku kein beispiel drin ist wie man sie mit reinem typoscript einbindet!

  2. Huhu

    Ich habe jetzt wt_twitter auf die übliche Art eingebunden:
    Erweiterung installiert, Contentelement erstellt, Template per TS zugewiesen.

    Jedoch habe ich ein Problem mit dem Cache. D.h. ich müsste nach jedem Twitter-Post den Cache der Starseite (nur hier eingebunden) löschen..

    Habe ich eine Einstellungsmöglichkeit übersehen oder wie regele ich das?

Kommentare sind geschlossen.